Error: Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference.

Solution :

This error is  occurred due the php version 5.3 and joomla is not certified to work with PHP 5.3.0.

You need to change some code in your files.

open the file
vi /home/username/public/modules/mod_mainmenu/helper.php

You can change this :
Form

function buildXML(&$params)

to

function buildXML($params)

Save the file try to access your site.

 

open the
/public_html/libraries/joomla/html/html.php

and find the (line 87)
return call_user_func_array( array( $className, $func ), $args );

put & sign before the $args
finally
return call_user_func_array( array( $className, $func ), &$args );