Strict standards messages should not be displayed by PHP as they are disabled by default. Please edit your php.ini and change the error_reporting option to:
error_reporting = E_ALL & ~E_NOTICE

It’s not related to joomla 1.6 but to the way your PHP 5 settings are.

php.ini file modify the line number: 516

replace   this line :

error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

Now its working fine.